Problem with portsdb

Bill Moran wmoran at
Wed May 4 12:04:01 PDT 2005

Jim Campbell <jim-c at> wrote:

> Let me preface this by saying that I am a newbie at FreeBSD specifically 
> and the *NIX world in general.
> I have checked the archives and found problems similar to mine, but 
> cannot find what to do to fix the problem.
> I have installed FreeBSD 4.11-Stable on my machine.  I run "cvsup" to 
> update my ports collection.  I then run "portsdb -uU" to update the 
> INDEX.db file.  This gives me two warning messages about duplicate index 
> entries for "freeciv-gtk-1.14.2" and "fvwm-imlib-2.4.19".  I can run 
> "make index" with the same results.  However, I can run "make describe" 
> with no error messages.  If I run "whereis freeciv-gtk" it is found 
> whereas "whereis fvwm-imlib" is not found.

Because the ports tree changes continuously, it's about a 50/50 shot
(in my opinion, actual numbers may differ) that you'll get a version
that can build a full index.  Everything has to be 100% perfect for
an index to build, as far as I can tell.

You'd do much better to "cd /usr/port && make fetchindex" to download
the latest successful index build from the Internet.

> I believe that I read that the /usr/ports/INDEX file is downloaded with 
> "cvsup" (?).  If so and I run "portsdb -u" then the INDEX.db file is 
> built from the INDEX file that was downloaded.  If I do this, I get no 
> warning message.  I am guessing that "portsdb -uU" rebuilds the INDEX 
> file from the contents of the port tree.  If so, then something is amiss 
> in my port tree. Is this correct?
> Is this a serious problem that needs fixing?  If so, how do I go about 
> fixing it?  In baby steps, please :=)

Yes, it' needs fixing, but it's generally something the ports folks have
to take care of, and they have an automated system that warns them when
index isn't building, so they already know.

Bill Moran
Potential Technologies

More information about the freebsd-ports mailing list