FreeBSD Port: ruby18-1.8.2_2

Jeremy Messenger mezz7 at
Mon Feb 21 21:35:46 PST 2005

On Mon, 21 Feb 2005 20:24:06 -0500, Garance A Drosihn <drosih at>  

> At 5:10 PM -0600 2/21/05, Jeremy Messenger wrote:
>> My lastest patch was:
> I tried this on powerPC, and ruby built fine.  I haven't tested
> it much, but the things I tested seem to work fine.
> I tried it on sparc64, and ruby didn't build.  The attempt
> ended with:

Ruby has few '__sparc__' and '__sparc_v9__' in the very few places, but  
none of '__sparc64__'. Are there any chance that it will need to add a new  
define, '__sparc64__', to make ruby works better? I am lacking on knowlege  
of programming, so someone with the programming knowledge should take a  
look at those.

# find . -name \* | xargs egrep -l "sparc"

Looks like about four to five files that need to take a look at.


> Looking in the work directory, it seems the bus error came up
> while running mini-ruby:
> work/ruby-1.8.2/miniruby.core
> gdb tells me:
> Core was generated by `miniruby'.
> Program terminated with signal 10, Bus error.
> (gdb) backtrace full
> #0  0x0000000040859d5c in __vfprintf () from /lib/
> I noticed the other email message which talked about the settings
> of CFLAGS, so I changed my /etc/make.conf
> from:
>       CFLAGS= -O -pipe
> to:
>       CFLAGS+= -O -pipe -g
> This changed the resulting 'cc' commands
> from:
>        cc -O -pipe   -fPIC -I. -I. -c main.c
> to:
>        cc -O2 -fno-strict-aliasing -pipe -O -pipe -g   -fPIC -I. -I. -c  
> main.c
> This still core-dumps.  I wondered if it might be significant that
> "something" wanted this to be -O2, but my CFLAGS was setting a -O.
> So I moved the line for '.include <>' such that it
> was before any of the lines which set CFLAGS in the makefile  (I
> put it right after GNU_CONFIGURE=yes).  That didn't change anything.
> All the 'cc' commands came out the same, and mini-ruby core-dumped.
> So then I tried commenting-out the setting of CFLAGS in my
> /etc/make.conf file.  That gave me 'cc' commands of:
>       cc -O2 -fno-strict-aliasing -pipe   -fPIC -I. -I. -c main.c
> but it still just core-dumps.  I then tried to make it with DEBUG=yes,
> and used gdb to step through it.  It does start in main, and it
> executes several thousand instructions before it dies.

mezz7 at  -  mezz at
FreeBSD GNOME Team  -  gnome at

More information about the freebsd-ports mailing list