octave build failed in atlas on releng_6

Ranko Sredojevic surija at gmail.com
Sun Dec 25 19:04:08 PST 2005


  Hi all,

I was playing around and upgrading from RELENG_6_0 to RELENG_6.

I started by deleting all the ports... cleaned everything so

pkg_info

wasn't reporting anything.

Then I changed tag in my cvs-supfile to RELENG_6 from RELENG_6_0,
and cvsup-ed (ports-all,src-all).

I rebult world, precompiled kernel in first try.
After that, I rebuilt xorg, gnome, latex, vim, xmms, gaim and subversion
without any problems. However, rebuilding octave finished, after 18hours
with:

ATLAS install complete.  Examine
ATLAS/bin/<arch>/INSTALL_LOG/SUMMARY.LOG for details.
(cd /usr/ports/math/atlas/work/ATLAS; /bin/mkdir -p tmp1 ;  /bin/cp
/usr/ports/m
ath/atlas/work/lapack/work/LAPACK/SRC/liblapack.a tmp1 ; cd tmp1 ; ar x
liblapac
k.a ; ar x ../lib/NON_THREADED/liblapack.a ; ar r
../lib/NON_THREADED/libalapack
.a *.o ; ranlib ../lib/NON_THREADED/libalapack.a )
ar: creating ../lib/NON_THREADED/libalapack.a
(cd /usr/ports/math/atlas/work/ATLAS; /bin/mkdir -p tmp2 ; /bin/cp
/usr/ports/m
ath/atlas/work/lapack/work/LAPACK/SRC/liblapack.a tmp2 ; cd tmp2 ; ar x
liblapac
k.a ; ar x ../lib/THREADED/liblapack.a ; ar r ../lib/THREADED/liblapack.a
*.o ;
ar: ../THREADED/liblapack.a: No such file or directory
*** Error code 9

Stop in /usr/ports/math/atlas.
***Error code 1

Stop in /usr/ports/math/octave.

I tried building in single user mode, since last time I was told to try not
to load
machine with anything in order to get atlas compiled properly.

I compiled octave before in RELENG_6_0 just fine. Any clue/cure?

rasha


More information about the freebsd-ports mailing list