seemingly unfixable Spinlock error under 5.3?

Andrew Moran amoran at
Sat Nov 13 13:49:30 PST 2004

I made the jump from 5.21 to 5.3 earlier and started getting the 
infamous "Fatal error 'Spinlock called when not threaded.' at line 83 
in file /usr/src/lib/libpthread/thread/thr_spinlock.c (errno = 2)" 
everytime I ran gnucash.

According to the release notes and previous posts, the problem comes 
from the port being linked against two threading libraries (libkse, 
libc_r, libpthread, or whatnot).  The solution is to recompile the port 
and everything it depends on, or to be safe, recompile all your ports.

I've done an ldd -a on everything in /usr/local and /usr/X11R6 and I 
can't see to find anyhing other than libpthread and libqthreads 
(installed by guile).      I've  recompiled gnucash with portupgrade -R 
gnucash to no avail.     I then tried reinstalling ALL my ports using 
'portupgrade -fa'.      This is after I upgraded to 5.3 by syncing the 
world, rebuilding and reinstalling the kernel, installing a new world, 
and resyncing the ports tree.

I still seem to get that error with gnucash.

Also, running 'strace -f gnucash'  just hangs indefinitely with no 
output.  I don't know if that's a clue.       Since gnucash is a guile 
program, I'm not sure how to debug where the spinlock issue is coming 

I asked the freebsd-questions list but have gotten no response.    So 
in desperation, I'm broadening my quest.    I don't want to reinstall 
the server from scratch if there is another way to fix this error.   
Could there be something in my kernel configuration causing this?   I 
can't find a reference to libc_r or libkse *anywhere*.  :/

Does anyone have any ideas for me to try?     Thank you for your time.


More information about the freebsd-ports mailing list