ports/163193: [PATCH] Fix port skippy-xd for amd64 arch

Vincent Hoffman-Kazlauskas vince at unsane.co.uk
Mon Dec 12 00:40:02 UTC 2011

>Number:         163193
>Category:       ports
>Synopsis:       [PATCH] Fix port skippy-xd for amd64 arch
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    freebsd-ports-bugs
>State:          open
>Class:          change-request
>Submitter-Id:   current-users
>Arrival-Date:   Mon Dec 12 00:40:01 UTC 2011
>Originator:     Vincent Hoffman-Kazlauskas
>Release:        9.0-PRERELEASE (9-STABLE)
FreeBSD ostracod.unsane.co.uk 9.0-PRERELEASE FreeBSD 9.0-PRERELEASE #16 r228059: Mon Nov 28 19:40:38 GMT 2011     root at ostracod.unsane.co.uk:/usr/obj/usr/src/sys/OSTRACOD  amd64
This port wasnt working for me on an amd64 system. I have not tried on i386.
A quick google around found 
The sed in the second comment fixed it for me.

install and try to run skippy-xd on an amd64 system.

Patch attached with submission follows:

--- Makefile.orig	2011-12-12 00:16:33.000000000 +0000
+++ Makefile	2011-12-12 00:13:31.000000000 +0000
@@ -24,10 +24,19 @@
 PKGMESSAGE=	${WRKDIR}/pkg-message
+.include <bsd.port.pre.mk>
 	@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|; \
 		s|/usr/local|${LOCALBASE}|; s|gcc|${CC}|' \
+.if ${ARCH} == "amd64"
+	@${REINPLACE_CMD} -e 's|CARD32|CARD64|g' ${WRKSRC}/clientwin.c
+	@${REINPLACE_CMD} -e 's|CARD32|CARD64|g' ${WRKSRC}/skippy.c
+	@${REINPLACE_CMD} -e 's|CARD32|CARD64|g' ${WRKSRC}/wm.c
+	@${REINPLACE_CMD} -e 's|CARD32|CARD64|g' ${WRKSRC}/wm.h
 	@${SED} 's|%%DATADIR%%|${DATADIR}|' ${PKGDIR}/pkg-message >${PKGMESSAGE}
@@ -39,4 +48,4 @@
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>


More information about the freebsd-ports-bugs mailing list