ports/139379: [PATCH] devel/rubygem-activesupport: add dependency on converters/ruby-iconv

Alexander Logvinov avl at FreeBSD.org
Tue Oct 6 13:40:04 UTC 2009


>Number:         139379
>Category:       ports
>Synopsis:       [PATCH] devel/rubygem-activesupport: add dependency on converters/ruby-iconv
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-ports-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Tue Oct 06 13:40:03 UTC 2009
>Closed-Date:
>Last-Modified:
>Originator:     Alexander Logvinov
>Release:        7.2-STABLE i386
>Organization:
>Environment:
>Description:
 I can't create Rails project without ruby-iconv port installed.

$ pwd
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.4

$ fgrep -R "require 'iconv'" *
lib/active_support/inflector.rb:require 'iconv'

 And it would be nice to add the same dependency to mail/rubygem-actionmailer:

$ pwd
/usr/local/lib/ruby/gems/1.8/gems/actionmailer-2.3.4

$ fgrep -R "require 'iconv'" *
lib/action_mailer/vendor/tmail-1.2.3/tmail/quoting.rb:        require 'iconv'

>How-To-Repeat:
$ pkg_info -Ix iconv
libiconv-1.13.1     A character set conversion library

$ rails test
undefined method `camelize' for "app":String

% pkg_info -Ix iconv
libiconv-1.13.1     A character set conversion library
ruby18-iconv-1.8.7.160,1 An iconv wrapper class for Ruby

$ rails test
      create  
      create  app/controllers

>Fix:


Patch attached with submission follows:

Index: Makefile
===================================================================
RCS file: /home/pcvs/ports/devel/rubygem-activesupport/Makefile,v
retrieving revision 1.19
diff -u -r1.19 Makefile
--- Makefile	10 Sep 2009 17:12:19 -0000	1.19
+++ Makefile	6 Oct 2009 13:20:09 -0000
@@ -6,6 +6,7 @@
 
 PORTNAME=	activesupport
 PORTVERSION=	2.3.4
+PORTREVISION=	1
 CATEGORIES=	devel rubygems
 MASTER_SITES=	RF
 
@@ -13,6 +14,7 @@
 COMMENT=	Utility classes and extension that are required by Rails MVC Framework
 
 USE_RUBY=	yes
+USE_RUBY_FEATURES=	iconv
 USE_RUBYGEMS=	yes
 RUBYGEM_AUTOPLIST=	yes
 


>Release-Note:
>Audit-Trail:
>Unformatted:



More information about the freebsd-ports-bugs mailing list