ports/131299: multimedia/vlc: does not compile any more, wuth luiveMedia support

Ollivier Robert roberto at keltia.freenix.fr
Thu Feb 5 00:05:21 UTC 2009

According to roberto at FreeBSD.org:
> Responsible-Changed-From-To: freebsd-ports-bugs->jsa at wickedmachine.net
> Responsible-Changed-By: roberto
> Responsible-Changed-When: Wed Feb 4 23:44:22 UTC 2009
> Responsible-Changed-Why: 
> Over to maintainer.
> http://www.freebsd.org/cgi/query-pr.cgi?pr=131299

The real fix is to modify the liveMedia Makefile to properly add
-fpic/-fPIC (the latter on amd64 at least).  The Makefile adds it to CFLAGS
but it is not taken into account.

I quickly tried to add it to the config.fixed-freebsd in liveMedia/files/
and compile succeeds.  Haven't tried to run it yet.

Cc: to liveMedia maintainer.

I keep the vlc maintainer in Cc; because the way vlc tries to use a static
library is somehow fishy.
Ollivier ROBERT -=- FreeBSD: The Power to Serve! -=- roberto at keltia.freenix.fr
Dons / donation Ondine : http://ondine.keltia.net/

More information about the freebsd-ports-bugs mailing list