ports/141828: graphics/sane-backends 1.0.20 doesn't compile on FreeBSD 8

Peter Palmreuther pitpalme+unix at gmail.com
Tue Dec 22 09:36:12 UTC 2009


On 12/22/09 at 09:17am, Pav Lucistnik wrote:
> Peter Palmreuther píše v po 21. 12. 2009 v 22:49 +0100:
> 
>>> Synopsis: graphics/sane-backends 1.0.20 doesn't compile on FreeBSD 8
>>>
>>> This port is known to build in a clean test environment.  Have you upgraded
>>> from 7.X?  Do you happen to have libusb installed?  
>>
>> I have in fact upgraded from 7.2 and I do have libusb installed. As it
>> won't compile anymore too (but with a message it's been integrated into
>> system) I hesitated to remove, before sane-backends recompiled successfully.
> 
> Yes, please delete libusb from your system. It has been integrated to
> the base system in 8.0, and the 7.2 package is probably conflicting with
> it now.
> 
> If that doesn't help, post a new transcript.

Thanks a lot. It turned out my hesitation to remove libusb was the
reason. Once removed, sane-backends compiled successfully.

Got to figure out the reason for scanning trouble yet, but that's a
different story.
-- 
Regards,

Peter.



More information about the freebsd-ports-bugs mailing list