ports/98893: cc error at -O2 on amd64/6-STABLE compiling port ucspi-tcp

Andrew Reilly andrew-freebsd at areilly.bpc-users.org
Sat Jul 8 15:47:34 UTC 2006


On Sat, Jul 08, 2006 at 12:40:51PM +0000, Tilman Linneweh wrote:
> Synopsis: cc error at -O2 on amd64/6-STABLE compiling port ucspi-tcp
> 
> State-Changed-From-To: open->feedback
> State-Changed-By: arved
> State-Changed-When: Sat Jul 8 12:39:45 UTC 2006
> State-Changed-Why: 
> I tried on CURRENT, and it does not seem to be a problem.
> 
> Can you perhaps try to reproduce it on CURRENT?
> 
> http://www.freebsd.org/cgi/query-pr.cgi?pr=98893

Not easily.  We'll see.  Maybe I'll give it a go soon.  What
version of GCC is cc on CURRENT?  The problem seems to be
restricted to -O2 in 3.4.4 (20050518).  Works fine at -O2 in GCC
4.1, or -O in 3.4.4, which is how I'm running it now.

I did try, for a while, to produce a simple test case that
demonstrated the same fault, but failed.  The simple test cases
that I produced all worked as expected.  There must be something
non-obvious going on with tcpserver as a whole (or at least a
largeish chunk of it.)

Sorry I can't be of more immediate use.

Cheers,

-- 
Andrew



More information about the freebsd-ports-bugs mailing list