ports/102341: multimedia/vlc - 0.8.5_5 "make install" error

Adi Pircalabu apircalabu at bitdefender.com
Mon Aug 21 11:50:26 UTC 2006


>Number:         102341
>Category:       ports
>Synopsis:       multimedia/vlc - 0.8.5_5 "make install" error
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    freebsd-ports-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Mon Aug 21 11:50:13 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     Adi Pircalabu
>Release:        6.1-STABLE
>Organization:
BitDefender
>Environment:
FreeBSD apircalabu 6.1-STABLE FreeBSD 6.1-STABLE #6: Fri Aug 18 12:17:00 EEST 2006     root at apircalabu:/usr/obj/usr/src/sys/GERULA  i386
>Description:
After lastest cvsup for the ports tree I can't install vlc. Looks like it's closely related to ldconfig.

http://lists.freebsd.org/pipermail/freebsd-multimedia/2006-August/004642.html

Extras from make install:

install  -o root -g wheel -m 444 /usr/ports/multimedia/vlc/work/vlc-0.8.5/doc/vlc.1 /usr/X11R6/man/man1/
install  -o root -g wheel -m 444 /usr/ports/multimedia/vlc/work/vlc-0.8.5/doc/vlc-config.1 /usr/X11R6/man/man1/
if [ ! -d /usr/X11R6/share/applications ]; then  /bin/mkdir -p /usr/X11R6/share/applications ;  fi
if [ ! -d /usr/X11R6/share/pixmaps ]; then  /bin/mkdir -p /usr/X11R6/share/pixmaps ;  fi
install  -o root -g wheel -m 444 /usr/ports/multimedia/vlc/files/wxvlc.desktop /usr/X11R6/share/applications
install  -o root -g wheel -m 444 /usr/ports/multimedia/vlc/work/fake/share/vlc/vlc48x48.png /usr/X11R6/share/pixmaps/vlc.png
===>   Compressing manual pages for vlc-0.8.5_5
===>   Running ldconfig
/sbin/ldconfig -m /usr/X11R6/lib
===>   Installing ldconfig configuration file
cannot create /usr/X11R6/libdata/ldconfig/vlc: No such file or directory
*** Error code 2

Stop in /usr/ports/multimedia/vlc.

>How-To-Repeat:
Update the ports tree then go to /usr/ports/multimedia/vlc and run make install
>Fix:
As a temp. fix comment USE_LDCONFIG= yes in Makefile and re-run make install
>Release-Note:
>Audit-Trail:
>Unformatted:



More information about the freebsd-ports-bugs mailing list