ports/80745: XFree86-4 fails to see wheel on Logitec MediaPlay mouse

Cy Schubert cy at cwsent.com
Sun May 8 05:30:03 UTC 2005


>Number:         80745
>Category:       ports
>Synopsis:       XFree86-4 fails to see wheel on Logitec MediaPlay mouse
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-ports-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Sun May 08 05:30:02 GMT 2005
>Closed-Date:
>Last-Modified:
>Originator:     Cy Schubert
>Release:        FreeBSD-2.0
>Organization:
FreeBSD
>Environment:
System: FreeBSD cwsys 5.4-STABLE FreeBSD 5.4-STABLE #0: Fri May 6 13:10:43 PDT 2005 root at cwsys:/export/obj/opt/src/cvs-stable5/src/sys/KOMQUATS i386


>Description:
XFree86-4 cannot see wheel movemt on a Logitec MediaPlay mouse.
>How-To-Repeat:
Install a Logitec MediaPlay mouse.
>Fix:


Index: files/patch-programs::Xserver::hw::xfree86::os-support::xf86OSmouse.h
===================================================================
RCS file: files/patch-programs::Xserver::hw::xfree86::os-support::xf86OSmouse.h
diff -N files/patch-programs::Xserver::hw::xfree86::os-support::xf86OSmouse.h
--- /dev/null	1 Jan 1970 00:00:00 -0000
+++ files/patch-programs::Xserver::hw::xfree86::os-support::xf86OSmouse.h	8 May 2005 04:25:49 -0000
@@ -0,0 +1,11 @@
+--- programs/Xserver/hw/xfree86/os-support/xf86OSmouse.h.orig	Fri Feb 13 15:58:46 2004
++++ programs/Xserver/hw/xfree86/os-support/xf86OSmouse.h	Sat May  7 21:18:57 2005
+@@ -299,7 +299,7 @@
+ /* Generalize for other axes. */
+ #define MSE_NOAXISMAP	MSE_NOZMAP
+ 
+-#define MSE_MAXBUTTONS	12
++#define MSE_MAXBUTTONS	16
+ #define MSE_DFLTBUTTONS	 3
+ 
+ #endif /* _XF86OSMOUSE_H_ */


Apply the above patch, then add the following to XF86Config:

    Option "Buttons"     "15"
    Option "ZAxisMapping" "14 15"
    Option "Resolution" "800"

Finally add the following to .xsession:

xmodmap -e "pointer = 1 2 3 6 7 8 9 10 11 12 13 14 15 4 5"

A similar bug exists in Xorg which has been documented in PR ports/80744
and in XFree86 as bug #1537 (also Xorg bug 2389).
>Release-Note:
>Audit-Trail:
>Unformatted:



More information about the freebsd-ports-bugs mailing list