ports/80491: Dependency error between packages prebuilt.

LI Dong ld at ldconfig.com
Sat Apr 30 23:20:02 UTC 2005


>Number:         80491
>Category:       ports
>Synopsis:       Dependency error between packages prebuilt.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-ports-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Sat Apr 30 23:20:01 GMT 2005
>Closed-Date:
>Last-Modified:
>Originator:     LI Dong
>Release:        FreeBSD 5.4-RC3 i386
>Organization:
NO
>Environment:
FreeBSD monalisa.ldconfig.com 5.4-RC3 FreeBSD 5.4-RC3 #1: Sun May 1 00:24:37 CEST 2005 root at monalisa.ldconfig.com:/usr/src
/sys/i386/compile/MONALISA i386

>Description:
      Dependency error between packages prebuilt.
        1) docproj-jadetex will install a noX version of ghostscript-gnu, which will overwrite
        the one with X11 installed by kde WITHOUT ANY warning.
        2) psutils-a4 should be conflict with psutils-letter, but we can install both they two
        WITHOUT ANY warning.

>How-To-Repeat:
      1)
        pkg_add -r kde
        pkg_add -r docproj-jadetex
        2)
        pkg_add -r psutils-a4
        pkg_add -r psutils-letter
>Fix:
      Add CONFLICT in Makefile, but I didn't touch these Makefiles because the maintainer may correct
        them very easy.
>Release-Note:
>Audit-Trail:
>Unformatted:



More information about the freebsd-ports-bugs mailing list