ports/69675: Eclipse slow typing

Bjorn Dittmer-Roche bjorn at sccs.swarthmore.edu
Tue Jul 27 19:10:14 UTC 2004


>Number:         69675
>Category:       ports
>Synopsis:       Eclipse slow typing
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-ports-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Tue Jul 27 19:10:13 GMT 2004
>Closed-Date:
>Last-Modified:
>Originator:     Bjorn Dittmer-Roche
>Release:        freebsd 4.9
>Organization:
XO Audio
>Environment:
FreeBSD twiggy 4.9-STABLE FreeBSD 4.9-STABLE #4: Fri Apr  2 19:46:37 EST 2004     root at twiggy:/usr/obj/usr/src/sys/TWIGGY  i386
>Description:
      I am working on a large java project in eclipse. Since updating my ports collection recently, i have a problem. When I first start up Eclipse everything is fine. After using it for a bit, most functions continue to work (compiling, running, etc) but when I type it is EXTREMELY slow. For example, I might type a word and the charaters will come out one at time at the rate of about one or two per second. Cutting and pasting seems fine. Also, I often notice that the insertion marker is often not in the same place as where you are typing. It can be off by several pixels and sometimes as much as a charactor.

   Also, possibly related, the new spell check feature seems broken. When I right click on text and select spell check, it loads a page at the bottom that says "Java Spell Checker (Loading...)" and that's it.
>How-To-Repeat:
      Update eclipse from the ports collection (I used portupgrade). Load a large java project. type and edit for a while. notice that it is painfully slow.
>Fix:
      
>Release-Note:
>Audit-Trail:
>Unformatted:



More information about the freebsd-ports-bugs mailing list