ports/70914: devel/apache-ant ignores JAVA_HOME when reinstall

Rong-En Fan rafan at infor.org
Tue Aug 24 19:10:29 UTC 2004


>Number:         70914
>Category:       ports
>Synopsis:       devel/apache-ant ignores JAVA_HOME when reinstall
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-ports-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Tue Aug 24 19:10:29 GMT 2004
>Closed-Date:
>Last-Modified:
>Originator:     Rong-En Fan
>Release:        FreeBSD 4.10-RELEASE-p2 i386
>Organization:
NTU CSIE 
>Environment:
System: FreeBSD muse.csie.ntu.edu.tw 4.10-RELEASE-p2 FreeBSD 4.10-RELEASE-p2 #1: Mon Jul 12 20:06:43 CST 2004 root at muse.csie.ntu.edu.tw:/home/admin/usr/obj/home/admin/usr/src/sys/MUSE i386


	
>Description:
	devel/apache-ant ignores JAVA_HOME when make reinstall

	
>How-To-Repeat:
	cd /usr/ports/devel/apache-ant
	make clean && make JAVA_HOME=/usr/local/jdk1.4.1 install
	[...]
	===>   apache-ant-1.6.2 depends on file: /usr/local/jdk1.4.1/bin/java - found
	it's good..

	make clean && make JAVA_HOME=/usr/local/jdk1.4.1 reinstall
	[...]
	===>   apache-ant-1.6.2 depends on file: /usr/local/diablo-jdk1.3.1/bin/java - not found

	It complete ignores JAVA_HOME as it try to use the
	default JAVA_HOME which is diablo-jdk1.3.1

	
	
>Fix:
	I have report similar situation on java/eclipse before,
	the pr is 
	http://www.freebsd.org/cgi/query-pr.cgi?pr=65479

	and that seems fixed. I think that might be a way
	to fix this.
	


>Release-Note:
>Audit-Trail:
>Unformatted:



More information about the freebsd-ports-bugs mailing list