ports/48913: vtk does not compile with nvidia-drivers installed

Christoph Moench-Tegeder cmt at rz.uni-karlsruhe.de
Mon Nov 17 17:43:25 UTC 2003


## Kirill Ponomarew (krion at FreeBSD.org):

> State-Changed-From-To: open->feedback 
> State-Changed-By: krion
> State-Changed-When: Mon Nov 17 01:35:06 PST 2003
> State-Changed-Why: 
> Does this problem still exist ? 

Yes:
c++ -o vtk tkAppInit.o  -L. -O2 -D__NO_MATH_INLINES -D_THREAD_SAFE  -fPIC -I.  -
I./../common -I../common -I/usr/local/include/tk8.3/generic -I/usr/local/include
/tcl8.3/generic  -I/usr/X11R6/include   -I/usr/X11R6/include   -I./../graphics -
DVTK_USE_GRAPHICS -I./../imaging -DVTK_USE_IMAGING -I./../contrib -DVTK_USE_CONT
RIB      -L/usr/ports/math/vtk/work/vtk3.2/contrib -lVTKContribTcl -lVTKContrib
         -L/usr/ports/math/vtk/work/vtk3.2/imaging -lVTKImagingTcl -lVTKImaging 
-L/usr/ports/math/vtk/work/vtk3.2/graphics -lVTKGraphicsTcl -lVTKGraphics       
-L../common -lVTKCommonTcl -lVTKCommon  -L/usr/X11R6/lib -L/usr/X11R6 -lGL -lOSMesa   -L/usr/local/lib -ltk83 -L/usr/local/lib -ltcl83     -L/usr/X11R6/lib -lXext -lXt -lSM -lICE -lX11 -lstdc++ -lgcc -pthread -lm
/usr/X11R6/lib/libOSMesa.so: undefined reference to `_glapi_Dispatch'
/usr/X11R6/lib/libOSMesa.so: undefined reference to `_glapi_add_entrypoint'
/usr/X11R6/lib/libOSMesa.so: undefined reference to `_glapi_get_context'
/usr/X11R6/lib/libOSMesa.so: undefined reference to `_glapi_get_dispatch_table_size'
/usr/X11R6/lib/libOSMesa.so: undefined reference to `_glapi_check_multithread'
/usr/X11R6/lib/libOSMesa.so: undefined reference to `_glapi_set_context'
/usr/X11R6/lib/libOSMesa.so: undefined reference to `_glapi_set_dispatch'
/usr/X11R6/lib/libOSMesa.so: undefined reference to `_glapi_noop_enable_warnings'
/usr/X11R6/lib/libOSMesa.so: undefined reference to `_glapi_Context'
*** Error code 1

Stop in /usr/ports/math/vtk/work/vtk3.2/tcl.
*** Error code 1  

Stop in /usr/ports/math/vtk/work/vtk3.2.
*** Error code 1  

Stop in /usr/ports/math/vtk.

This does not happen on another machine where I do not use nvidia drivers.
This could be caused by a problem with libglut I discovered today, libglut
does not link against libGL on the machine with nvidia-drivers installed.
Perhaps this is a local problem caused by broken packages?

Regards,
Christoph

-- 
Spare Space.



More information about the freebsd-ports-bugs mailing list