ports/52906: vid-1.0.1 from ports does not work with USB camera after upgrade from 4.4 to 4.7

Dmitry A.Deineka axl at itl.ua
Tue Jun 3 15:30:14 UTC 2003


>Number:         52906
>Category:       ports
>Synopsis:       vid-1.0.1 from ports does not work with USB camera after upgrade from 4.4 to 4.7
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-ports-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Tue Jun 03 08:30:11 PDT 2003
>Closed-Date:
>Last-Modified:
>Originator:     Dmitry A.Deineka
>Release:        FreeBSD 4.8-RELEASE i386
>Organization:
iTL Company
>Environment:
System: FreeBSD vault.itl.net.ua 4.8-RELEASE FreeBSD 4.8-RELEASE #11: Tue May 6 16:38:14 EEST 2003 axl at vault.itl.net.ua:/var/obj/storage/vol2/src/sys/VAULT13 i386


Intel 440BX platform, PIII, Tekram SCSI etc. Problem is not
platform/hardware depended.
>Description:
vid-1.0.1 works well with Genius USB camera (similar to Creative
webcams) based on OV511 or OV511+ chipsets. After upgrade from
4.4 to 4.7 vid-1.0.1 failed to communicate with webcam with following
error:

vid: couldn't locate an OV511 or OV511+ device

USB section on kernel config:

device          uhci
device          ohci
device          usb
device          ugen

>How-To-Repeat:

Install FreeBSD 4.4.
Install vid-1.0.1 from ports (/usr/ports/graphics/vid) and pnmtopng
Connect USB camera

Execute following code:
/usr/local/bin/vid --small | /usr/local/bin/pnmtopng > /tmp/image.png

You will make shot from your cam.

Upgrade to 4.7 or 4.8 and try to produce image. You will receive
error:
vid: couldn't locate an OV511 or OV511+ device

>Fix:




>Release-Note:
>Audit-Trail:
>Unformatted:



More information about the freebsd-ports-bugs mailing list