home router with internal services available question [SOLVED] - followup

Greg Hennessy Greg.Hennessy at nviz.net
Tue Mar 6 19:50:32 UTC 2007

> Greg suggested that I do a tcpdump -s 96 -nleti pflog0 to see what was
> going on.

Do you have pflog_enable="YES" 

Set in /etc/rc.conf ? Is pflog0 visible as up and running in the output of
ifconfig -a ?

> I tried that and got no data captured, not a single entry.
> one of my /etc/rc.conf variables is a pflog_path="/var/log/pflog"
> and that file has data in it, but it is hex data I'm assuming as ascii
> tools didn't work to read the file.

That's in raw tcpdump packet capture format, you can view the contents using
tcpdump with the '-r' rather than the '-I' option. 

> And I honestly don't know enough here to ask a good question, tcpdump
> found the pflog0 interface and warned that no ip address was
> configured, something that makes some sense so didn't really concern
> me.
> Once again, can you point me in the right direction please.

Easily done :-)



More information about the freebsd-pf mailing list