possible PR?

Scott Robbins scottro at nyc.rr.com
Mon Oct 18 18:38:58 PDT 2004

I have run into the following issue--I'm not sure how unique my
situation may or may not be, which is why I'm not sure if it merits a PR
or not.
FreeBSD 5.3-BETA7.  This is an upgrade from 5.2.1 and I have the
compat4x libraries.

I had openoffice-1.1.3 installed.

I attempted to do a portupgrade of openoffice as follows
portupgrade -Rr -m WITHOUT_JAVA=yes -m WITHOUT_MOZILLA=yes.

It failed (I'll give more specifics in a moment.)
I then tried uninstalling OO completely and removed all distfiles
in the /usr/ports/distfiles/openoffice-1.1/ directory.

I tried doing it WITHOUT_JAVA=yes and WITHOUT_MOZILLA=yes and then tried
doing it while leaving those two out.  

This is the output--this is from an example where I didn't do

==>  Extracting for openoffice-
>> Checksum OK for openoffice1.1/OOo_1.1.4.20041012_source.tar.bz2.
>> Checksum OK for openoffice1.1/gpc231.tar.Z.
>> Checksum OK for openoffice1.1/patch-openoffice-mozilla101-2002-10-14.
>> Checksum OK for openoffice1.1/mozilla-vendor-1.0.2a.tgz.
===>   openoffice- depends on file:
/usr/local/bin/perl5.8.5 - found
===>  Patching for openoffice-
===>   openoffice- depends on file:
/usr/local/bin/perl5.8.5 - found
===>  Applying FreeBSD patches for openoffice-
Ignoring previously applied (or reversed) patch.
1 out of 1 hunks ignored--saving rejects to
>> Patch patch-1.1.3-1.1.4 failed to apply cleanly.
*** Error code 1

Stop in /usr/ports/editors/openoffice-1.1-devel.
** Command failed [exit code 1]: /usr/bin/script -qa
/tmp/portupgrade78762.1 make
** Fix the problem and try again.

The rejected hunk is

*** 5,11 ****
  			PRODUCTNAME OpenOffice.org
--- 5,11 ----
  			PRODUCTNAME OpenOffice.org

My /etc/make.conf has X_WINDOW_SYSTEM=xorg and BATCH=yes--aside from
that I believe everything is standard.  

I am not knowledgeable enough to know what other information is
essential--I have looked at the pr guide, and hope that I am giving
enough information.  

I have searched the pr's and don't find this issue.  I have also read
/usr/ports/UPDATING and don't find it.  Lastly I searched the mailing
lists (specifying current, questions, ports and ports-bugs) without
finding it.

Thank you for your time and I apologize if my lack of knowledge means
that I have sent the wrong information or not sent sufficient

Most sincerely


Scott Robbins

PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver pgp.mit.edu --recv-keys EB3467D6

Xander: What do you feel?
Anya: Upset, afraid of being without you, and a little hungry.
Xander: I meant about the house.
Anya: Oh. Still haunted.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-openoffice/attachments/20041018/2cf8069a/attachment.bin

More information about the freebsd-openoffice mailing list