Getting functional ipv6 on Century Link

Alan Somers asomers at freebsd.org
Sat May 26 15:51:01 UTC 2018


On Sat, May 26, 2018 at 9:01 AM, Sean Bruno <sbruno at freebsd.org> wrote:

> http://www.centurylink.com/home/help/internet/modems-and-
> routers/zyxel-c1100z/ipv6-turn-on.html
>
> US DSL carrier that seems to provide v6 via a 6rd configuration.  This
> all seems to be working and my modem reports it has stuff and things.
>
> What am I supposed to use as settings in rc.conf to enable client side
> ipv6?  Nothing I seem to do with router advertisement or whatever seems
> to be be correct.
>
> sean
>
>
I'm using IPv6 on CenturyLink .  My OpenWRT router's configuration looks
like this:
/etc/config/network:
...
config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.0.1'
        option ip6assign '64'

config interface 'wan'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username '*****'
        option password '*****'
        option ipv6 '1'

config interface 'wan6'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto '6rd'
        option peeraddr '205.171.2.64'
        option ip6prefix '2602::'
        option ip6prefixlen '24'
...
/etc/config/dhcp:
...

config dhcp 'lan'
        option interface 'lan'
        option limit '150'
        option leasetime '12h'
        option start '101'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
...

Behind the firewall, On my FreeBSD machines I simply have this in
/etc/rc.conf:
ifconfig_em0_ipv6="inet6 accept_rtadv"

Hope it helps.
-Alan


More information about the freebsd-net mailing list