[Bug 203922] The kern.ipc.acceptqueue limit is too low

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Sat Jan 16 21:15:22 UTC 2016


https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203922

--- Comment #6 from Alfred Perlstein <alfred at FreeBSD.org> ---
The correct way would be to retain the field as-is but rename it to "_old".

Then add a field with the correct width.

Then when exporting the field make sure to continue to export the _old struct
but carefully assign it using code as follows:
xpcb->qlen = newval
xpcb->qlen_old = qlen->qlen > (uint32_t)MAX_ISHORT ? MAX_USHORT : qlen->qlen

Then possibly mark the old field for deprecation, but still really shouldn't
deprecate if we intend to be forever backwards compatible.

To _really_ fix it, there really should be an accessor library written so that
no one has to even know the size of xpcb other than the library.

-- 
You are receiving this mail because:
You are the assignee for the bug.


More information about the freebsd-net mailing list