Intel 82574L interface wedging on em 7.1.9/7.2.3 when MSIX enabled

Jason Wolfe nitroboost at
Wed Oct 26 11:33:46 UTC 2011


I have run with dev.em.X.flow_control=0, which should have the same result
as hw.em.fc_setting=0, and net.inet.tcp.tso is also 0.  I'm not sure the
remaining options would be able to produce the scenario I'm seeing, but I'm
open to giving it a try with no options on the interfaces.  I've also added
ifconfig output to the collection.

ifconfig emX -rxcsum -txcsum -vlanhwtag -tso -wol

It's always TX, but these servers push ~12x what they receive, so I'm
guessing it could happen to either buffer given the right traffic patterns.
 While looking through commits I also found a patch to add a couple sysctls
for em, which I'm adding -


On Wed, Oct 26, 2011 at 3:33 AM, Hooman Fazaeli <fazaeli at> wrote:

> Hi Jason
> Have you tried:
> hw.em.fc_setting="0" (in loader.conf)
> ifconfig emX -tso -lro -rxcsum -txcsum -vlanhwtag -wol
> with MSIX and no multiqueue.
> Advanced features has always been a source of problem.
> It is worth a try and help to narrow down possibilities.
> It would also be helpful if you provide 'ifconfig' output
> when the problem happens.
>  And a question: Does interface RX also hangs or it is just TX?

More information about the freebsd-net mailing list