bridging vs wifi, proxy arp broken on 8.0 rc? (was: Re: Bridged networking for virtualbox on -current?)

Juergen Lock nox at
Sun Nov 22 23:37:41 UTC 2009

In article <4B09992F.1080900 at> you write:
>Doug Barton wrote:
>> Fredrik Lindberg wrote:
>>> Doug Barton wrote:
>>>> Is bridged networking for vbox supposed to work on -current? It says
>>>> on the wiki that it does, but I tried it tonight and couldn't get it
>>>> to work.
>>>> I did see one page that suggested trying one of the Intel virtual
>>>> nicks, which I did, no luck.
>>>> If this is not supposed to work it would be nice to update the wiki, I
>>>> spent quite a bit of time trying to get it to work that I hope was not
>>>> wasted.
>>> The short answer is that it should work.  The long answer is that
>>> it depends, for example it doesn't play nice when trying to
>>> bridge a virtual nic with an if_bridge interface.
>>> A slightly more verbose description of your environment and what
>>> error messages you're seeing would probably help.
>> Thanks. I'm using an up to date -current, and my outgoing nic is
>> wlan0. I followed the instructions on the wiki. I first tried the
>> default nic in OSE then I tried the first Intel nic on the list (which
>> required downloading drivers of course).
>Which type of virtual interface you're using in virtualbox doesn't
>matter. However, it hits me that I've actually never really tested
>the bridging code with a wireless interface and it looks like you've
>hit a bug.  I tried to use a wireless interface just now and it
>doesn't work, need to look into why though.

The problem with bridging and wifi is that on wifi you usually can
use only a single mac address...  There are ways around this (using
nat or routing), and I actually played with the latter using qemu tap
networking recently, but couldn't get the most ideal solution working
the way I wanted on 8.0 rc - it only worked on 7-stable.  (using a
sub-subnet of the lan interface for the tap interface + guest, and
routing + proxy arp for the guest ip.)  I just wanted to try it again
on the 8.0 rc box and now even setting up the prox arp entry fails
	arp: writing to routing socket: Invalid argument
Commands I tried:
	arp -s <guest ip> <host nic's mac> pub only
	arp -s <guest ip> auto pub only
(both before even configuring the tap interface this time...)

 Mind you my 8.0 rc checkout is a little old (Sep 29) so maybe I should
try updating first (I want to test 8-stable anyway one of these days) -
but looking for `arp' in the relevant commitlogs also came up empty. :(

 (I'm Cc'ing -net just in case, please keep me on the Cc cause I'm
not subscribed there...)


More information about the freebsd-net mailing list