PPPoE and Radius on 6.0RC1

Gleb Smirnoff glebius at FreeBSD.org
Thu Oct 20 05:59:13 PDT 2005

On Thu, Oct 20, 2005 at 12:31:59PM +0000, Marcin Jessa wrote:
M> > > On Wed, Oct 19, 2005 at 11:51:11PM +0200, Marcin Jessa wrote:
M> > > M> It seems like PPPoE stoped working with support for radius on 6.0
M> > > M> The log of pppoe and freeradius does not show pppoe attempting to
M> > > M> even talk to the radius server. Additionally this message pops up
M> > > M> when enabling pppoed: WARNING: attempt to net_add_domain
M> > > M> (netgraph) after domainfinalize() My setup worked fine before on
M> > > M> FreeBSD 5.x Is that a known issue and is it being worked on?
M> > > 
M> > > Please show your PPPoE server configuration. Do you use pppoed or
M> > > mpd?
M> > 
M> > I use pppoed.
M> > Adding 
M> > netgraph_load="YES"
M> > ng_socket_load="YES"
M> > to /boot/loader.conf fixed it on my 6.0RC1 ( thanks Julian Elischer )
M> > Frankly I don't understand why this is needed since pppoed loads those
M> > modules when it starts up.
M> Just tested the same setup on 7.0 built tonight and it did not work.
M> The pppoed daemon never sends any requests to freeradius...
M> I tried to additionaly with those modules listed in loader.conf with no
M> luck:
M> ng_ether_load="YES"
M> ng_pppoe_load="YES"

This is very strange. Because I have recently upgraded one router running
pppoed to 6.0-RC1 and I have no problems.

Please read on the pppoed logs and see what is the problem. If everything
is fine in pppoed logs, then go on with ppp logs. "stopped working" is not
really informative.

Totus tuus, Glebius.

More information about the freebsd-net mailing list