Why no sound? FIXED

Chuck Robey chuckr at telenix.org
Wed Dec 9 19:44:17 UTC 2009

Chuck Robey wrote:
> I haven't used my audio here for aboout a year now, but seeing as the connection
> setup I'm using used to work fine with FreeBSD, I think I can assume that I
> haven't any hardware misconnection problems, and my speaker system (which has
> spdif input) allows me to select an internal noise generator for speaker testing
> (balancing) so I know the speakers are OK also.
> My problem is that I can get no sound out at all.
> I've set my freebsd-current kernel with sound and snd-hda devices, and my
> /dev/sndstat prints:
> FreeBSD Audio Driver (newpcm: 32bit 2009061500/i386)
> Installed devices:
> pcm0: <HDA Analog Devices AD1988B PCM #0 Analog> at cad 0 nid 1 on hdac0
> [MPSAFE] (1p:1v/1r:1v channels duplex default)
> pcm1: <HDA Analog Devices AD1988B PCM #1 Analog> at cad 0 nid 1 on hdac0
> [MPSAFE] (1p:1v/0r:0v channels simplex)
> pcm2: <HDA Analog Devices AD1988B PCM #2 Digital> at cad 0 nid 1 on hdac0
> [MPSAFE] (1p:1v/0r:0v channels simplex)
> It's a Asus Striker Extreme motherboard, which has an internal ADI1988B chip,
> which seems to be recognized fine by dmesg.  I'm certain I'm using a good test
> mp3, and my connection is via spdif.  Mixer says all my outputs are on.  I can
> play DVDs via vlc, but still no sound.  I can find no documentation whatsoever
> in FreeBSD man pages as to what devices ought to be active here, but can anyone
> give me a  hint as to what else I might try?

This is embarrassing ... it's happens, no matter how long I really try to do my
homework FIRST, before asking for help, this is now the 3rd time I've solved my
own problem just after writing.  There has to be something psychological about
this ...

Anyhow, I was experimenting with the sysctls, it was the wrong default unit
being set.  It works now.

More information about the freebsd-multimedia mailing list