Testing MythTV 0.21 - no MPEG hardware cards?

Torfinn Ingolfsen torfinn.ingolfsen at broadpark.no
Tue Apr 21 15:25:53 UTC 2009


Please don't top post.

On Mon, 20 Apr 2009 09:59:34 -0700 (PDT)
Mark Busby <redtick at sbcglobal.net> wrote:

> I've been a using the pvrxxx, I tried the updated mythtv port within
> the last 30 days, I had the same result as Torfinn. My pvr-150 would
> not work. The last I read was the V4l needed work for it to run in
> freebsd. This may have changed. 

In case anyone is confused: IMO, pointing a fiunger at the pvrxxx port
at this time is _very_ premature.

pvrxxx has worked since usleep fixed it a few years back (of course
ther have been breakages now and then), and continues to work today. My
current production MythTV backend is a machine with a PVR-500 card,
root at kg-fil# uname -a
FreeBSD kg-fil.kg4.no 6.2-STABLE FreeBSD 6.2-STABLE #20: Mon Mar 12 23:04:49 CET 2007     root at kg-fil.kg4.no:/usr/obj/usr/src/sys/FIL60  amd64
root at kg-fil# pv | grep pvr
pvrxxx-20060822             =  up-to-date with port 
root at kg-fil# pv | grep mythtv
mythtv-0.20                 =  up-to-date with port 
root at kg-fil# mythbackend --version
Library API version: 0.20.20060828-3
Source code version: FreeBSD Ports Collection /usr/ports/multimedia/mythtv, MythTV version 0.20 Tue Mar 13 23:10:55 CET 2007
Options compiled in:
 freebsd release using_v4l using_oss using_arts using_ivtv using_dbox2 using_hdhr using_ip_rec using_freebox using_live using_x11 using_xv using_xrandr using_frontend using_backend

There is something wrong with the mythtv 0.21 port, I simply can't figure out why the "MPEG-2..." card type selection is missing from mythtv-setup. I have googled quite bit, but no clues so far.
Torfinn Ingolfsen

More information about the freebsd-multimedia mailing list