Problems with dri/drm using Radeon 7000 VE in -stable

Randall Creighton randy at
Wed Apr 23 17:04:24 PDT 2003

Wow, thats weird, I just bought the same card this weekend, I tried to 
install the kernel mods vi the port
/usr/ports/graphics/drm-kmod I didn't have any probs until I tried 
glxgears, glxinfo reports no direct rendering.
I ran out of weekend before I got any further, now I will just do what 
you did. Thanks for breaking trail!


Anders Nordby wrote:

>I tried applying
> to
>stable from today (using device radeondrm and options DRM_LINUX).
>Kernel reports drm seems to be there:
>drm0: <ATI Radeon QY RV100 VE> port 0x9000-0x90ff mem
>info: [drm] Initialized radeon 1.8.0 20020828 on minor 0
>Now, when I try to start XFree86 everything looks fine at first:
>root at noname:~# startx
>Using authority file /root/.Xauthority
>Writing authority file /root/.Xauthority
>Using authority file /root/.Xauthority
>Writing authority file /root/.Xauthority
>XFree86 Version 4.3.0
>Release Date: 27 February 2003
>X Protocol Version 11, Revision 0, Release 6.6
>Build Operating System: FreeBSD 4.8 i386 [ELF] 
>Build Date: 23 April 2003
>        Before reporting problems, check http://www.XFree86.Org/
>        to make sure that you have the latest version.
>Module Loader present
>Markers: (--) probed, (**) from config file, (==) default setting,
>         (++) from command line, (!!) notice, (II) informational,
>         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
>(==) Log file: "/var/log/XFree86.0.log", Time: Wed Apr 23 20:36:28 2003
>(==) Using config file: "/etc/X11/XF86Config"
>But I get this in /var/log/messages:
>Apr 23 20:36:29 noname /kernel: error: [drm:radeon_unlock] *ERROR*
>Process 338 using kernel context 0
>And glxinfo reports that I have no direct rendering (output:
> :(
>My XF86Config:
>Excerpt from pciconf -l -v output:
>drm0 at pci1:0:0:  class=0x030000 card=0x7112174b chip=0x51591002 rev=0x00
>    vendor   = 'ATI Technologies'
>    device   = 'Radeon VE QY Radeon 7000 / Radeon VE'
>    class    = display
>    subclass = VGA
>scanpci reports this about the Radeon:
>pci bus 0x0001 cardnum 0x00 function 0x00: vendor 0x1002 device 0x5159
> ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]
>How do I get dri/drm to work? Has anyone got dri/drm in -stable with
>XFree86 4.3.0 running?

More information about the freebsd-multimedia mailing list