Suspend/Resume problem on Thinkpad X201 (8-STABLE)

Scott Lambert lambert at
Mon May 24 17:05:16 UTC 2010

On Sat, May 22, 2010 at 06:20:15PM +0100, Geoffrey Ferrari wrote:
> Hi folks,
> I've just bought a Lenovo Thinkpad X201 which I plan to use as my main
> work machine (mainly, all I need is emacs + latex) I've a little past
> experience with FreeBSD (and Linux), but this is the first time I've
> committed to trying to use FreeBSD for my main work computer. I

> Now for my request for help :) My Thinkpad successfully enters sleep
> mode (that's ACPI level S3 - suspend to ram), but there are problems
> with resuming out of sleep mode. The main problem is that the LCD does
> not wake up upon resume, and simply stays black. The computer is
> actually awake when this happens though! I can e.g. logout (typing
> blindly) and I can even log in via ssh. However, the screen stays
> switched off. I read on some forums that some people have experienced
> a similar problem where their screen switches on but displays nothing,
> only a black background. But no, my screen doesn't even switch on!
> I've searched numerous forums and tried various things, but none of
> them resolve the problem and some make it worse! Here's a sample of
> what I've tried so far.
> Setting hw.acpi.video_reset=1 to loader.conf. This makes things worse.
> When I do this, my laptop refuses to wake from sleep at all.
> Loading the i915 driver in loader.conf. This seems to do nothing.
> Loading acpi_ibm in loader.conf. This seems to do nothing.
> Setting debug.acpi.disabled="YES" in sysctl.conf . This seems to do nothing.
> I've also tried switching from one virtual console to another, both
> via the keyboard, and by running "vidcontrol -s 2 > /dev/console".
> I've checked /var/log/messages after resume and it reports "Interrupt
> storm detected on irq9" - that's seems to be associated with ACPI.
> So, I'm writing to ask if anyone can help me to get my laptop to
> resume properly. I'm including some info below that my help someone to
> understand what's going on. I really love FreeBSD so I hope someone
> will be able to help me to get my laptop to sleep and wake reliably!

Are you in X when you sleep?  Have you tried after switching to ttyv0
first?  CTRL-ALT-F1 from X.

I have this in my rc.suspend, right after the creation of the
/var/run/ file.

/usr/sbin/vidcontrol -s 1 < /dev/ttyv0

I also unload the wireless driver in rc.suspend, and load it in
rc.resume.  But my wireless card's microPCI slot doesn't seem to get
fully renabled on resume yet.

Scott Lambert                    KC5MLE                       Unix SysAdmin
lambert at

More information about the freebsd-mobile mailing list