Asus EEE -- suspend, card reader and camera

Jack Twilley jmt at
Sun Dec 7 08:43:38 PST 2008

Paul B. Mahol wrote:
> On 12/7/08, Jack Twilley <jmt at> wrote:
>> Paul B. Mahol wrote:
>>> On 12/6/08, Jack Twilley <jmt at> wrote:
>>>> Paul B. Mahol wrote:
>>>>> On 12/6/08, Jack Twilley <jmt at> wrote:
>>>>>> Paul B. Mahol wrote:
>>>>>>> On 12/5/08, Jack Twilley <jmt at> wrote:
>>>>>>>> I am a mostly-happy user of an Asus EEE 701.  Recently I was pointed
>>>>>>>> at
>>>>>>>> which has more current information
>>>>>>>> than
>>>>>>>> the nighthack page.  I'm running RELENG_7 and I am pleased to confirm
>>>>>>>> that the wired Ethernet works out of the box.  I'm looking forward to
>>>>>>>> ath_hal merging from current so I can stop copying over the madwifi
>>>>>>>> hal
>>>>>>>> directory.  I have only three issues remaining, some of which are at
>>>>>>>> least partially discussed on that page.
>>>>>>>> First, I'm new to FreeBSD on laptops.  I tried to suspend with Fn-F1
>>>>>>>> and
>>>>>>>> it seemed to do the right thing, but I don't know how to resume.  I
>>>>>>>> tried Fn-F1 and it didn't work.  I hit the power button, and the LEDs
>>>>>>>> changed but the screen never woke up.
>>>>>>> loading vesa LKM fixed that issue for me, also make sure that
>>>>>>> kern.smp.disabled=1
>>>>>>> eg. add these lines to /boot/loader.conf
>>>>>>> vesa_load="YES"
>>>>>>> kern.smp.disabled="1"
>>>>>> I made those changes, and I see the same behavior -- it doesn't come
>>>>>> back with Fn-F1 or the power button.  How do you resume?
>>>>> You rebooted after that change?
>>>> Yes.
>>>> Jack.
>>> Well, then I dont know, maybe there is some driver attached on device
>>> that is cause of resume problem?
>>> You could try to disable all of them and try again.
>>> What happens if you suspend with zzz inside X11?
>>> I'm on i386, dunno if resume work at all on amd64.
>> zzz from an xterm does what Fn-F1 does.  No change in behavior.  I did
>> learn that it does "come back" when I hit the power button in the sense
>> that it responds to network connections like ssh, but the screen never
>> wakes up and I have to reboot it to fix it.
> Did you tried switching vtys, eg, to syscons and back? After resume
> keyboard is working?

I tried switching virtual consoles and the LCD never came back.  I did 
blindly log in as root and reboot, though, so keyboard works.  Looks 
like something's hinky with the LCD support.


>> uname says i386 and this box has a Celeron processor if I recall correctly.
>> Jack.

More information about the freebsd-mobile mailing list