Asus EEE -- suspend, card reader and camera

Paul B. Mahol onemda at
Fri Dec 5 23:08:04 PST 2008

On 12/6/08, Jack Twilley <jmt at> wrote:
> Paul B. Mahol wrote:
>> On 12/5/08, Jack Twilley <jmt at> wrote:
>>> I am a mostly-happy user of an Asus EEE 701.  Recently I was pointed at
>>> which has more current information than
>>> the nighthack page.  I'm running RELENG_7 and I am pleased to confirm
>>> that the wired Ethernet works out of the box.  I'm looking forward to
>>> ath_hal merging from current so I can stop copying over the madwifi hal
>>> directory.  I have only three issues remaining, some of which are at
>>> least partially discussed on that page.
>>> First, I'm new to FreeBSD on laptops.  I tried to suspend with Fn-F1 and
>>> it seemed to do the right thing, but I don't know how to resume.  I
>>> tried Fn-F1 and it didn't work.  I hit the power button, and the LEDs
>>> changed but the screen never woke up.
>> loading vesa LKM fixed that issue for me, also make sure that
>> kern.smp.disabled=1
>> eg. add these lines to /boot/loader.conf
>> vesa_load="YES"
>> kern.smp.disabled="1"
> I made those changes, and I see the same behavior -- it doesn't come
> back with Fn-F1 or the power button.  How do you resume?

You rebooted after that change?


More information about the freebsd-mobile mailing list