IBM A20m

Mark A-J. Raught (from the laptop) mraught at
Sat Mar 19 06:44:25 PST 2005

Jason Reynolds wrote:
> To Whom It May Concern:
> For the love of God - PLEASE help me I'm going completely INSANE!
> I have installed FreeBSD ver.5.3 (using FTP, I downloaded 

i386-bootONLY.iso, and i386-ver5.3.iso) onto my IBM A20m laptop.

After using the boot CD, I installed FreeBSD using the Wizard-like

  interface, I included ALL of the available options (this may have

  sealed my fate).  Anywhoo, everything appeared to be going fine, no

  errors, no warnings, then I came to reboot to complete the

  installation, I get the IBM screen (the one that tells you what

  BIOS version you have and what it is loading) this is what it says:
> IBM ThinkPad BIOS 4.0 Release 6.0.U
> Copyright 1985-1999 Phoenix Technologies Ltd.
> All Rights Reserved
> 640K System RAM Passed
> 127M Extended RAM Passed
> 256K Cache SRAM Passed
> System BIOS shadowed
> Video BIOS shadowed
> UMB upper limit segment address: I3P9
> Mouse initalized
> Fixed Disk 0: HITACHI_
> Press <F1> to enter SETUP
> Press <F12> to choose temporary boot device
> and thats it, after this screen it flashes a little, and goes blank.

   I have tried every function key, combined with every other key

(FUNCT key, Alt key, Ctrl key, Backspace) you name it. I cannot enter

  setup, or view anything.  I even tried using a desktop monitor, removed

  the hard drive and attempted to attach it to one of my desktop drive

  bays, it wouldn't fit using any of my existing CD, CD/RW and floppy

  plug-ins, although it did look like the pin patterns were the same,

  I didn't want to force anything.  I looked all over the web, there

  seems to be a very serious compatibility issue with the A20m, as

  described here:
> A bug in early revisions of IBM’s BIOS on these machines mistakenly

  identifies the FreeBSD partition as a potential
> FAT suspend-to-disk partition. When the BIOS tries to parse the

  FreeBSD partition it hangs.
> I downloaded this driver and followed the instructions, the

  screen is still blank, but I can hear the floppy drive working.  So

  before I spend $$ on a new motherboard, or a "parts" laptop, can you

  think of another solution for me.  I just wanted to try out FreeBSD.

   Show me some love.
> Jason
> ---------------------------------
> Do you Yahoo!?
>  Yahoo! Small Business - Try our new resources site! 
> _______________________________________________
> freebsd-mobile at mailing list
> To unsubscribe, send any mail to "freebsd-mobile-unsubscribe at"

I could be wrong, (not sure about specific A20 problems) but it sounds 
like you need to make the drive bootable. You can redo the install and 
make sure on the fdisk setup screen you hit (I think) s, the option to 
make the partition active, and then make sure on the later screen that 
asks about bootblock, make sure the install add the bootblock. I am 
going from memory here, there are three options: one is to do nothing, 
the next is to install the bootblock (I think that's what it is called) 
and the third is to install a boot manager. The one you want is the boot 
block one. There may be an easier way to do this, but since it is a new 
install, this may be the quickest.

As for putting the drive in a desktop machine: you need a converter. 
they are available at most computer shops for $5 to $15. The difference 
is that laptop drives get power through the cable and desktop drives 
have a separate power connector. Just make sure you are careful to get 
the cable set to pin one correctly or you can possibly fry the drive. 
Everything is usually well marked.

If this info doesn't help, send another email and I'll setup a test 
machine to get definite screen names and options for the above bootblock 
selections, but you should be able to figure out the right selections 
from the (rather vague) ideas in the first paragraph.


More information about the freebsd-mobile mailing list