Suspend/Resume not working on thinkpad T42

David Scheidt dscheidt at
Thu Jun 16 22:49:01 GMT 2005

On Thu, Jun 16, 2005 at 05:53:48PM -0400, Parv wrote:
> in message <20050616213320.GA12473 at>, wrote David Scheidt
> thusly...
> >
> > Suspend and resume (acpiconf -s 3) doesn't work on my T42 (a
> > 2378-DXU).  Well, that's not strictly true.  Suspend seems to work
> > fine, but resume doesn't.  The machine either doesn't resume at
> > all, or it comes back but won't respond.  It worked in a 5.3 as
> > off the first of the year.  I don't know when it broke.
> Suspend/resume (S3) has been working for me ever since i started to
> use it in 5.3 after some configuration.  Right now i am using
> 5.3-p16 on 2373-5TU (T42) machine.  I can suspend/resume from X or
> console just fine.  BTW, In case of resuming directly in X, i have
> to disable dri module, thus glx module.
> You did not mention which version of FreeBSD you are using NOW, or
> how you suspend/resume, or what happen on resume.

FreeBSD lightbulb 5.4-STABLE FreeBSD 5.4-STABLE #0: Thu Jun 16
17:07:18 EST 2005     root at lightbulb:/usr/obj/usr/src/sys/LIGHTBULB

It really does nearly nothing on resume.  The sleep LED goes out.
Rarely, the machine appears to wake up.  However, it doesn't do
anything.  It doesn't respond to the network.  It will switch virtual
terminals, echo typing on the screeen, but nothing actually happens.
Once in, oh, 100 tries or so, it resumes properly.  As I said, it
worked fine with a -STABLE from the first of the year.

More information about the freebsd-mobile mailing list