Problem using Ndisulator - cannot configure Linksys WMP54g wireless

Bill Paul wpaul at FreeBSD.ORG
Wed Mar 17 15:54:59 PST 2004

> Hello!
> This is my first post on the list, so please do not kick me too hard :)
> Playing with Ndisulator (Project Evil), found that my 1000Base-t Dlink DGE- 
> 510T card
> worked perfectly using supplied windows drivers. Thanks Bill Paul!
> But I still cannot get to work my WMP54G wireless pci card.
> In WindowsXP it works very well, but I couldn't configure it right in 
> FreeBSD.
> if_ndis loads, ndis0 interface comes up, but I cannot change ssid or 
> channel using ifconfig of
> using sysctl. I used drivers from Linksys and Dell with same result.
> So, does anybody have like problem, or, maybe, solution?

Lesson number one: don't tell, show. Don't tell me "it doesn't work."
_Show_ me. Show me the commands you typed. Show me the results you
saw (i.e. error/status messages).

The correct way to set the ssid of your NIC is to do:

# ifconfig ndis0 netmask 0xffffff00 ssid myssid media autoselect up

That's for infrastructure mode, i.e. with an actual AP. If you want
to use ad-hoc mode, do:

# ifconfig ndis0 netmask 0xffffff00 ssid myssid mediaopt adhoc up

You can scan for networks to attach to using:

# wicontrol -i ndis0 -l

You can't set the channel, so don't worry about that for now.


-Bill Paul            (510) 749-2329 | Senior Engineer, Master of Unix-Fu
                 wpaul at | Wind River Systems
              <adamw> you're just BEGGING to face the moose

More information about the freebsd-mobile mailing list