ACPI & pcmcia problem

Alexandre Ahmim-Richard passe at
Sun Mar 14 17:09:28 PST 2004

tl3i at wrote:
> Hi, I have the same controller, and I had the same problem.
> At first I remarked that disabling acpi all goes right, but acpi on a laptop
> is quite essential :D
> I solved dumping the DSDT table, correcting this and so recompiling; look
> for acpidump and iasl tools.
> So I put in loader.conf to load my DSDT.aml file (acpi_DSDT etc...) and
> now it's ok.

I dumped and decompiled it, I tried to recompile it to search for 
warnings or errors, it gives me 3 warnings :

mulet.dsl  2063:                             Store (Local0, BST0)
Warning  2079 -                 Statement is unreachable ^

mulet.dsl  2473:                 Method (STM, 0, Serialized)
Warning  2019 -                            ^ Not all control paths 
return a value (STM_)

mulet.dsl  2879:     Method (_WAK, 1, NotSerialized)
Warning  2026 -                 ^ Reserved method must return a value (_WAK)

> My laptop is a gericom advance 1400, have you a similar machine?

I have the same laptop, if it's possible, can you provide your fixed dsdt ?

Alexandre Ahmim-Richard
passe at

More information about the freebsd-mobile mailing list