atheros adhoc mode

Sam Leffler sam at
Sun Sep 7 21:43:45 PDT 2003

> We're evaluating the Soekris 4801 and a 5212 based mini-PCI radio - It
> works well enough in infrastructure mode, but I'm having problems with
> adhoc.
> When the radio is operating in adhoc mode, I see multicast traffic, but
> no unicast traffic.  However, if I run tcpdump on the ath interface I get
> sporadic traffic.
> It's possible I'm still misconfigured, but the fact that putting the
> interface into promiscuous mode changes the behavior of the interface
> kinda points elsewhere.  We have this application running fine on 4521s
> with both an & wi radios.
> Is this a known problem?

No, but adhoc mode has not been well tested.  11a or 11b?  What version of
the software?  Have you tried enabling debugging and packet dumping on the
interface (ifconfig ath0 debug link2) to see what's happening?

If you're getting multicast traffic but not unicast then it sounds like the
BSSID isn't setup correctly--which was a very old bug.


More information about the freebsd-mobile mailing list