CD-RW problems on ThinkPad X23

Kevin Oberman oberman at
Thu May 22 16:25:27 PDT 2003

> Date: Thu, 22 May 2003 18:59:07 -0400
> From: Jesse Sheidlower <jester at>
> Sender: owner-freebsd-mobile at
> I have an IBM ThinkPad X23 running FreeBSD 4.8-STABLE, and am having
> various problems with my CD-RW drive. It's part of the Ultrabase,
> which is how the X-series laptops add some peripherals.
> I didn't do anything special to configure it; it just worked. I had
> previously used it to install some software, but I don't have any
> CD-ROMs around right now for testing. I had never tried anything
> else, since I didn't need to burn any CDs and I hadn't gotten around
> to getting sound support compiled.
> Now that I've done so, I find that I can't really do much. If I try
> to put in an audio CD, with the GUI CD Player app, I get the message,
> "Error accessing cdrom device. Please check to make sure cdrom drive
> support is compiled into the kernel, and that you have permission to
> access the device. Reason: no such file or directory." Using 
> cdcontrol on the command line, I get:
>   cdcontrol: no disc in drive /dev/acd0c
> even when there is. 
> Burning CDs doesn't work either; I constantly get:
>   monopoly/ # burncd data test.iso fixate
>   burncd: open(/dev/acd0c): Device not configured
> It does register on boot:
>   monopoly/ # dmesg | grep acd
>   acd0: CD-RW <CD-W28E> at ata1-master PIO4
> Any suggestions for where I should start to poke? I haven't found
> anything too helpful online.

The most obvious is permissions. Are you doing this as root or as a user?
If you ae running as root, do "ls -l /dev/acd*". What are the major and
minor modes? acd0a and acd0c should both should be 117 0. If they ae not,
delete them and "cd /dev;MAKEDEV acd0"

Hope this helps.

R. Kevin Oberman, Network Engineer
Energy Sciences Network (ESnet)
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab)
E-mail: oberman at			Phone: +1 510 486-8634

More information about the freebsd-mobile mailing list