Winbook X4/PSM0 Not Functioning

Mike Fish michaelcfish at
Sun Jul 6 03:00:35 PDT 2003

Dear friends,


I am having mouse problems on my laptop. I have done a clean install of 5.1R on a Winbook X4, Pent 4-M, 512MB RAM. Everything went fine except the touchpad mouse does not work. This is a FreeBSD problem as the touchpad works fine under Win XP.


I have changed "hint.psm.0.flags" within /boot/device.hints following advice from the FreeBSD web site and related resources but nothing has helped. I thought the problem might be with 5.1R but 4.8R has the same problem. 


If I boot with ACPI enabled or disabled seems to make no difference. This is really frustrating as I cannot use my mouse and thus also cannot use the PC. 


I have tried all possible combinations of mouse protocols and ports via the sysinstall utility; nothing has worked. While booting in verbose mode I get the following message from DMESG:


psmcpnp0 irq 12 on acpi0

psm0: current command byte:0065

psm0: the aux port is not functioning (2).


If someone could please offer advice as to how I may fix my problem, I would be extremely happy. :)




Michael Fish


Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!

More information about the freebsd-mobile mailing list