Bluetooth stack for FreeBSD ( test bcmfw )

Maksim Yevmenkin m_evmenkin at
Wed Apr 9 09:56:46 PDT 2003

Hello Takahiko,
> As we discussed on current at which is Planex GW-BH02U does not
> work on bluetooth stack. This product uses Broadcom BCM2033 module and
> you reached to solution, firmware patch for the module.
> I should report you when I tested bcmfw command. I've been installed
> 2003-04-07(patched) on Casio FIVA.  At first,  I tried to connect
> HSC HNT-UB01(MITSUMI Module).  Bluetooth stack looks fine.

good, thank you :)
> Next,  I tried to connect GW-BH02U.  This module found with ubt0.
> Of course hccommand still problem.  So, I should type following command
> on firm dir.
>    # bcmfw -n ubt0 -m BCM2033-MD.hex -f BCM2033-FW.bin
>    bcmfw[498]: Could not NgSendMsg(4, ubt0:, 1021837971, 7, 0xbfbffb6e,
>         2). No such file or directory (2)
> Unfortunately, I got following message on console and upgrade failure.
>    Allocationg major#249 to "ubt"
>    ubt0: at uhub0 port 1 (addr 2) disconnected
>    ubt0: detached
>    ugen0: Broadcom Corp. BCM2033, rev 1.01/0.a0, addr2

hmmm... that is strange... it seems device re-attached itself and then
ugen(4) driver attached to it. 
> I tried to solve with use gdb and trace bcmfw.  So, bcmfw called
> bcmfw_device_nodes twice.  First one should passed.  Second one show
> that syslog message to failure.  I don't know why but when firmware
> transfered to module,  just after ubt0 become detached.

i see. the first call to bcmfw_device_bcmfw_check_device() is to turn
*on* device nodes under /dev. the second call to bcmfw_device_nodes() 
is to turn them *off*

since you did not get any errors from bcmfw_check_device() and  
bcmfw_load_firmware() then i suspect the bcmfw(8) actually worked and
transferred firmware into the device.

it appears that device resets itself *after* firmware was downloaded and
that caused "detach" message you saw. when device is detached Netgraph
node is destroyed and that causes "Could not NgSendMsg()" error. next,
ugen(8) driver attached to the device. i wonder why. we already claimed
that device, so why just not re-attach the same driver? got to get back
to USB source code...
> I should test continuously, If this report becomes help you for fix problem.

thank you very much for trying it and reporting the results. i will try
to find workaround.


Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more

More information about the freebsd-mobile mailing list