First RSPRO deployed !

Milan Obuch freebsd-mips at
Thu Nov 11 23:00:06 UTC 2010

On Thursday 11 November 2010 12:14:30 Luiz Otavio O Souza wrote:


> >> I'm running a slightly modified version of current (for the RTC support
> >> and basic multi-phy/switch support - still without vlan support).
> > 
> > Could you share your changes/patches? I have this board too and could
> > benefit from it too... you did a bit more already than me...
> Hi Milan,
> Sure, all my patches/changes are available, but as i said, it's only small
> changes...

Do you have a summary somewhere?


> >> The only problem i had was with the WPA - hostapd - setup (never did it
> >> before, so i probably have screwed the setup).
> > 
> > If you could show config, maybe someone could help you. I have tested WPA
> > setup with two FreeBSD systems and Atheros cards and it worked. I could
> > use my FreeBSD AP as an internet gateway for wifi enabled Nokia E66,
> > too, so I think a verified it a bit :) and this kind of things should
> > not be arch dependent :)
> Here is my config (ifconfig - rc.conf):
> hostapd_enable="YES"
> wlans_ath0="wlan1"
> create_args_wlan1="wlanmode hostap mode 11g descr wireless-ap"
> ifconfig_wlan1="ssid wpa-test channel 1"

In my case, rc.conf is this:

create_args_wlan0="wlanmode ap"
autobridge_bridge0="fxp0 wlan0"

> My hostapd.conf:
> (have tried with and without preamble, with eapol_version = 1 and 2 and
> with wpa = 1 and 3)

and my:

wpa_pairwise=CCMP TKIP

This is all and it works... tested with Nokia E66.


> >> It's running fully static, booting a gziped kernel from onboard flash
> >> and with a full system on a 8GB SD card (i've another two 4GB
> >> memsticks, one is used for ports and the other for sources and obj).
> > 
> > Again, it would be great if you could share your experience - I would
> > like to run from flash too, but did not came there yet, I am still only
> > at netboot stage with USB flasdisk based file system.
> > 
> > Regards,
> > Milan
> adrian@ keeps a wiki page with some information about this:

I know about this page... actually, I am using patches mentioned there, 
downloaded from so I can use 

Also, I use attached kernel config, but this needs some changes. For RTC a 
patch is probably necessary. GPIO definition needs to be changed a bit. I did 
not test any miniPCI card yet. Maybe again some patch is needed...

I found - do you use any patch from 

Last thing coming from your dmesg - where did you get driver for switch 
connected to arge1 and what could you do with it?

-------------- next part --------------
ident		AR71XX
options 	ISA_MIPS32
makeoptions	KERNLOADADDR=0x80050000
options		HZ=1000

files		"../atheros/files.ar71xx"
hints		"AR71XX.hints"

makeoptions	DEBUG=-g			# Build kernel with gdb(1) debug symbols
makeoptions	MODULES_OVERRIDE=""

options		DDB
options		KDB

options		SCHED_4BSD			# 4BSD scheduler
options		INET				# InterNETworking
options		PSEUDOFS			# Pseudo-filesystem framework
options		_KPOSIX_PRIORITY_SCHEDULING #Posix P1003_1B real-time extensions

device		pci

device		mii
device		arge

device		usb
options		USB_EHCI_BIG_ENDIAN_DESC	# handle big-endian byte order
device		ohci
device		ehci
device		umass
device		scbus
device		da

device		gpio
device		gpioled

device		spibus
device		ar71xx_spi
device		mx25l

device		geom_label
options		ROOTDEVNAME=\"ufs:/dev/ufs/MIPSroot\"

device		ar71xx_wdog

device		uart

device		loop
device		ether
device		md
device		bpf
device		random
device		if_bridge

More information about the freebsd-mips mailing list