svn commit: r211280 - in head/sys: conf mips/conf mips/include mips/mips mips/rmi

M. Warner Losh imp at
Fri Aug 13 14:51:40 UTC 2010

In message: <201008131256.o7DCu0lS006909 at>
            "Jayachandran C." <jchandra at> writes:
:   Rename TARGET_XLR_XLS to CPU_RMI to match other CPU_xxx definitions.
:   use CPU_RMI all XLR configurations. Update ident string for N32 and
:   N64 kernels.

I think that we may need more granularity than CPU_CNMIPS in the
future (since there's already two types of CNMIPS we support, with a
third one on the horizon).  Older bits of code have a finer grained
support for CPUs, but that's not currently that consistent inside of
the tree.

Traditionally, the CPU_xxxx has been used both for size control, as
well as behavior tweaking.  The majority of the support in the tree
today with CPU_CNMIPS and CPU_XLR is only for the latter.


More information about the freebsd-mips mailing list