net-p2p/vuze (formerly known as azureus)

Conrad J. Sabatier conrads at
Sat Feb 4 03:09:15 UTC 2012

Has anyone had any actual success at getting Vuze 4.7.x to work
properly?  I've been tinkering with it for days now, and it's still not
behaving properly.

In Vuze's logs, I'm seeing lots of "class not found" type errors,
mostly in the mozilla/XPCOM hierarchy.  I've fiddled with classpaths,
swapping various jars in and out, tuning variables in the launcher
script, rebuilding name it, I've tried it.  Still, I
can't get it to perform one single cotton-pickin' search properly.
Every attempt to search triggers yet another "class not found" type of
error and the search goes nowhere fast.

In researching this thing online, I came across a number of additional
search engine templates that can be added to Vuze, but even those didn't
help with the broken search functionality.  Still the same issue with
the missing classes.

I've tried it with both the swt-devel and swt ports (both of which
I've rebuilt as well), to no avail. I've explictly added mozilla-related
libraries to the LIB_PATH defined in the script, toyed with using
libxul, xulrunner, etc.  Still, it's pathetically broken with regards to

I'm just wondering if *anyone* has gotten anywhere with this thing.  It
looks like it could be quite a nice bittorrent client if it would just
*work*, lots of features and customizations and plugins to play with.

After two solid days of messing with this thing, I'm about ready to
give up, unless someone has some helpful advice to offer.

Frankly, this is beginning to remind me why I've always had a certain
distaste for all things Java.  Such a labyrinth it is to try to wade
through when things go wrong.  And such an odd language in some ways.
What *were* the designers thinking, for instance, when they decided that
the "main" method would be of type void and return no value?  Clearly a
different school of thought from the old Unix way.

Ah well, don't mean to sound like an old sourpuss here.  Any helpful
hints from anyone who's had any luck with this thing would be much

Oh, incidentally, I've tried using both diablo-jdk and openjdk, both
yielding the same results.

Thanks to anyone who might have some insight to offer here.

Conrad J. Sabatier
conrads at

More information about the freebsd-java mailing list