Oracle SQL Developer

Marcin Cieslak saper at system.pl
Mon Jan 14 05:09:26 PST 2008


martinko wrote:
> Marcin Cieslak wrote:
>>> Would someone care to port Oracle's SQL Developer to FreeBSD, please ?
>>>
>>> <http://www.oracle.com/technology/products/database/sql_developer/index.html>

>> There is actually nothing to port, just download the non-JRE platform
>> independent zip file, unpack and run "bash sqldeveloper" from
>> sqldeveloper/sqldeveloper/bin directory.
>>
>> Works for me (7.0-BETA3 on amd64, self-compiled sun jdk15 from ports).

> I've tried it on 6-STABLE (6.2.something) and it got stuck at splash
> screen.  Btw, I've noticed output like this in terminal:
> 
> expr: illegal option -- X
> usage: expr [-e] expression
> expr: illegal option -- D
> usage: expr [-e] expression

I have this as well.

> Also, all the scripts use #!/bin/bash which doesn't work in FreeBSD.
> And I'd like to install it in /usr/local/... so that all users can use
> it and it can be included in portaudit checks and checked for upgrades
> via ports system, etc etc.

It's okay - but first you need to get it working.

After those "expr" messages I get:

Using oracle.home=/usr/home/saper/sw/sqldeveloper
Using ide.user.dir=/usr/home/saper/.sqldeveloper
Addin: Translator PlSql is trying to register a input type (.plsql)
which con
2008-01-14 14:05:17 oracle.dbtools.raptor.timesten.TTAddin initialize
SEVERE: Cannot find TimesTen JDBC jar files in CLASSPATH

and the tool is working (haven't tried connecting though).

using

java version "1.5.0_13-p7"
Java(TM) 2 Runtime Environment, Standard Edition (build
1.5.0_13-p7-root_03_dec_2007_00_10)
Java HotSpot(TM) 64-Bit Server VM (build
1.5.0_13-p7-root_03_dec_2007_00_10, mixed mode)

Maybe your Java VM does not start up? Are other java apps running?
This may be related to some diablo-jdk problems reported on the -java
list recently.


--Marcin



More information about the freebsd-java mailing list