Eclipse hangs at splashscreen

GerritKühn gerrit at
Tue Mar 15 09:22:05 PST 2005

Hi folks,

I've had this problem months before: Eclipse displays the splashscreen when
starting, but after that nothing more happens. The java process remains in
state "kserel". I can kill eclipse, which makes the splash go away, but the
java process remains (in state "STOP" now) forever.
Back then this was caused by mixed threading libs (at least I thought so),
and I could make work by setting up an appropriate libmap.conf.
However, about two weeks ago I suddenly saw this behaviour again.
Well, meanwhile I did two gnome-updates, one kde-update, one perl-update and
some smaller updates on this machine, so I think the threading-lib problem
is not an issue anymore (at least I cannot find old links using ldd on
randomly chosen binaries). So I gave it a try without libmap and with
different entries than I used before (libkse, libc_r, libpthread, I tried
each and every combination).
Strange enough, it /sometimes/ worked for some startups of eclipse, but then
went back to the behaviour described above, so maybe the reason lies
elsewhere?! Just to make sure, I recompiled eclipse with portupgrade -R -f,
but the problem is still there. Meanwhile, I havn't been able to start
eclipse for two days (and I tried it quite a lot of times :-).

This is the only machine where I see this problem. I have several other
machines here (running 5.2.1 and 5.3-stable), which all work fine. The one
with the problem is running 5.3-STABLE, latest eclipse and jdk14 from ports.
However, the only real difference to the other boxes may be that it's an SMP
station (2 x P3-933).

Are there any hints how to get eclipse started on this machine again? I'd
really like to do my software development on it, because it has plenty of
RAM and is the fastest box around.



More information about the freebsd-java mailing list