eclipse

Jonathan Chen jonc at chen.org.nz
Sun Mar 6 06:06:15 GMT 2005


On Sat, Mar 05, 2005 at 07:19:01PM -0500, kalin mintchev wrote:
> 
> hi all..
> 
> i sent this to the genereel bsd list but i haven't gotten any relys. maybe
> here i'll have more luck...
> 
> i'm trying to run the linux eclipse on a 5.3 release. i have all the java
> set up. when i tried to run it i got:

Not a good move. Linux binaries under FreeBSD are buggy, problematic
at best.

> /usr/local/eclipse/eclipse: error while loading shared libraries:
> libgtk-x11-2.0.so.0: cannot open shared object file: No such file or
> directory
> 
> so i got the rpm for gtk2-2.4.13-2.1.src.rpm and installed using rpm. i
> didn't get any errors with the rpm and now i have libgtk* under
> /usr/X6R11/lib

Looks like you trashed your FreeBSD binaries here. Linux binaries
are generally installed /usr/compat/linux/* via the ports. You can't
install Linux rpm's directly under FreeBSD.

> it wasn't libgtk-x11-2.0.so.0 but libgtk-x11-2.0.so.400. so i lnked it like:
> 
> #ln -s /usr/X11R6/lib/libgtk-x11-2.0.so.400
> /usr/X11R6/lib/libgtk-x11-2.0.so.0
> 
> i also tried linking it under /usr/compat/linux/usr/X11R6/lib.
> 
> still nothing...
> 
> where is eclipse looking for those libs?

Here's a thought: Why don't you use the FreeBSD port for eclipse
instead?
-- 
Jonathan Chen <jonc at chen.org.nz>
----------------------------------------------------------------------
"If you wish your merit to be known, acknowledge that of other people"


More information about the freebsd-java mailing list