Still doesn't work

Panagiotis Astithas past at
Thu Dec 29 10:22:59 PST 2005

Franco Bruno Borghesi wrote:
> 2005/12/23, Franco Bruno Borghesi <fborghesi at>:
>>Hi again. I'm still having problems with eclipse + jdk15 on amd64. Eclipse
>>crashes continuously and the only thing that seems to make it work (at least
>>for a couple of hours) is erasing the .metadata directory (and loosing all
>>the configuration settings).
>>Panagiotis said it was a gc problem, and suggested me to look here<>for a switch that makes java
>>work.I tried different switches, some from that page and some I found
>>googling (not many), but nothing seems to work.
>>The fact that only Panagiotis answered my questions makes me think that
>>none of you have experienced this kind of problem, although Panagiotis said
>>it was a common problem (is it?).
>>So, my question is: has anyone experienced this problem? how do you deal
>>with it? have you found any switch to make java work?
>>I'm thinking maybe I shoud go back and use freebsd 32 on my amd64... is
>>this what you people do?
>>Thanks... and merry Christmas to all of you :-)
> Googling around I've found this jdk bug
> 5060628<http://>(
> I don't know if the problem they describe there is the same problem that
> Panagiotis was talking about, and I also ignore if it is actually my
> problem, but I decided to give a try to the proposed fixes.
> Running eclipse with "-vmargs -Djava.compiler=" seems to solve the
> problem.Eclipse runs slower but stable, no hangs at all (at least for the
> last couple of days).
> The other proposed solution was to create a file called ".hotspot_compiler"
> with the following contents:
> exclude  org/eclipse/jdt/internal/compiler/parser/Scanner
> optimizedCurrentTokenSource3
> exclude org/eclipse/jdt/internal/core/util/CommentRecorderScanner
> recordComment
> This is said to be a better solution, but it didn't work for me. It's not
> clear to me where I should create the file, so I tryed with
> /usr/local/eclipse/.hotspot_compiler, ~/.hotspot_compiler and
> ~/.eclipse/.hotspot_compiler.
> Hope this helps anyone with the same problem.
> Cheers.

Interesting. So this is a bug in hostspot:compiler2 on amd64 that is 
fixed in jdk 1.5 update 6 (build 4) and mustang (build 59). Since the 
mustang source is available perhaps we could obtain the relevant fix. 
However it is available under the JRL not SCSL. Can we do this and then 
legally distribute the jdk?



More information about the freebsd-java mailing list