[fixed] jdk-1.5 update to _3 does not work under freebsd 6 stable

Greg Lewis glewis at eyesbeyond.com
Thu Dec 15 10:16:16 PST 2005


Hi Melvyn,

On Thu, Dec 15, 2005 at 01:20:01AM +0100, Melvyn Sopacua wrote:
> attached are all patches that resulted in a succesful build for me and firefox 
> showing in about:plugins:
> Java(TM) Plug-in 1.5.0-p2-root_14_dec_2005_21_49
> 
>     File name: libjavaplugin_oji.so
>     Java(TM) Plug-in 1.5.0
> 
> They might include bits of patches already in the port as some files already 
> had a .orig.
> 
> In short - I took the shortest route to getting the plugin implementation to 
> accept PRThread * in place of JDUint32/nsPluginThread, fixed an include patch 
> for moved headers and disabled the obsoleted NS_COMPONENT_MANAGER_CID with an 
> #ifdef.

Thanks!  Have you successfully tested the plugin with some of the example
applets that come with the JDK?  Also, I wasn't sure that disabling
NS_COMPONENT_MANAGER_CID was the right thing to do.  It looked like that
may mean the plugin doesn't do the right thing with LiveConnect.  Comments?

-- 
Greg Lewis                          Email   : glewis at eyesbeyond.com
Eyes Beyond                         Web     : http://www.eyesbeyond.com
Information Technology              FreeBSD : glewis at FreeBSD.org


More information about the freebsd-java mailing list