eclipse

Bruno Van Den Bossche brvdboss at spymac.com
Tue Apr 5 13:17:28 PDT 2005


Alex Varju wrote:
> Bruno Van Den Bossche wrote:


>   http://www.varju.ca/alex/freebsd/eclipse-devel-3.1m6-2.tgz
> 
> I know that there are still a few things wrong still.  I tried a Motif 
> build on my i386 box yesterday, and it will compile, but crashes during 
> startup.  I don't know what's going wrong there.  Also, the 
> libswt-mozilla library is not getting compiled under gtk-amd64 right 
> now, and I'm having trouble convincing the build to do what I want.
> 
> Once I get these issues resolved, I'll submit my port.

Ok, great work!

>> Ok, I did earlier today and there seems to a strange thing going on
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=90155
>>
>> The getId() method actually returns a String and not a long as the 
>> compiler seems to think.  I haven't got a clue why the compiler thinks 
>> it's a long.  If you (or anyone for that matter) have any clue, feel 
>> free to pitch in :)
> 
> That is strange.  As you say, it sure does look like the getId() method 
> is returning a String, so I don't know why it would claim otherwise. The 
> whole build is complicated by the fact that Eclipse is using its own 
> compiler to do a lot of the work, so this error message is probably not 
> coming directly from javac.  Now that I think of it, though, have you 
> tried compiling that same code with javac?  That might help narrow the 
> problem down to either our compiler or theirs.

The bug has been solved!
I just found what was wrong when I noticed I got an e-mail from bugzilla 
with the solution :)  (Try the eclipse-source tree in eclipse, it's a 
nightmare!)

The getId() method that was actually called wasn't from 
AbstractWebBrowser but from Thread :-/  It's one of those classic bugs.
That'll teach me from just trying the quick fix without investigating :-/

So the fix should be (as mentioned in the bug-report):
DefaultBrowserSupport.getInstance().removeBrowser(ExternalBrowserInstance.this.getId());

Bruno


More information about the freebsd-java mailing list