Still cannot build native JDK1.4 with FreeBSD 5.3.

Achilleus Mantzios achill at
Fri Dec 17 02:45:32 PST 2004

O Nick Sayer έγραψε στις Dec 16, 2004 :

> A month ago, I reported problems building the native JDK14 port. I 
> haven't gotten any responses. I can't believe I'm the only one in the 
> world who is seeing this failure.
> I'm running with RELENG_5_3. I have a working Linux 1.4 JDK installed.

Have you tried to verify that your linux linux-sun-jdk- is
working indeed? (try some apps, especially javac)

> To recap, the build fails spitting out about a hundred errors about 
> various interfaces not being public and what not. At the bottom, it 
> looks like this:
> ../../../src/share/classes/java/net/ cannot 
> resolve symbol
> symbol  : method getHostName ()
> location: class
>              out.write(epoint.getHostName().length());
>                              ^
> Note: Some input files use or override a deprecated API.
> Note: Recompile with -deprecation for details.
> 100 errors
> gmake[4]: *** [.compile.classlist] Error 1
> gmake[4]: Leaving directory 
> `/usr/ports/java/jdk14/work/j2se/make/java/java'
> gmake[3]: *** [optimized] Error 2
> gmake[3]: Leaving directory 
> `/usr/ports/java/jdk14/work/j2se/make/java/java'
> gmake[2]: *** [all] Error 1
> gmake[2]: Leaving directory `/usr/ports/java/jdk14/work/j2se/make/java'
> gmake[1]: *** [all] Error 1
> gmake[1]: Leaving directory `/usr/ports/java/jdk14/work/j2se/make'
> gmake: *** [j2se-build] Error 2
> *** Error code 2
> Stop in /usr/ports/java/jdk14.

Have you tried make clean and start all over the build?

Also a check for mem,disk,CPU overheating, would be very good.
When it seems that we are the only people in the world
who have a problem, then most of the cases it is a hardware

FreeBSD (unlike window$,linux) does not like bad hardware.
Once i was building some world, i got a compile error on gcc source on a 
line like
#dufine ... ...
As far as i could remember, this was the first (and last)
occasion in my life that i encountered this mysterious
precompiler directive!

My CPU was probably overheated, or my memory was bad.
(I changed CPU,mem,disk).

The funny thing is that in a lot of bad memory related cases, other s/w 
(including previous releases of FreeBSD) may have run fine,
leading to many false alarms about a new release.


More information about the freebsd-java mailing list