Another jdk build error on -CURRENT

Jens Rehsack rehsack at
Fri Oct 3 03:43:03 PDT 2003

Hi Alexey,

after I patched out all '-O3' flags as recommented, the build failed
again at the same place with the same core dump. By the way, the hint
of Thomas to use the debug versions worked fine. Everytime the build
stops with core dump, I link the debug executables those ones without
debug (ln -f $file_g $file).

Now I'm getting 2 new errors:
1) Because of the -Werror in j2se/make/java/nio/Makefile (already
    in and added by patch for bsd platform), gcc3.3.1 fails because
    _LITTLE_ENDIAN is already defined. Setting both occurances to
    -Wno-error solved that.
2) In the makefiles is the threading linkage different between
    -STABLE and -CURRENT, j2se/ext/plugin/build/solaris/GNUmakefile
    seems to does not. The following error results:

gmake[2]: Entering directory
gcc -Wall   -o

-L/usr/X11R6/lib \
gcc: The -pthread option is deprecated.
gmake[2]: ***
[/usr/ports/java/jdk14/work/control/build/bsd-i586/bin/java_vm] Error 1
gmake[2]: Leaving directory
gmake[1]: *** [plugin-all] Error 1
gmake[1]: Leaving directory `/usr/ports/java/jdk14/work/j2se/make'
gmake: *** [j2se-build] Error 2
*** Error code 2

More information about the freebsd-java mailing list