Yet another problem building /usr/ports/java/jdk14

Doug Poland doug at
Thu May 29 08:45:14 PDT 2003


I had to remove a working JDK1.4 from a 4-STABLE machine and am now having problems
re-building from the port.

Here's a snip from the build....

Compiling /usr/ports/java/jdk14/work/hotspot/src/share/vm/runtime/functionAtEnd.cpp
echo Linking vm... ; \
g++ -shared -mimpure-text  -z noversion -o functionAtStart.o accessFlags.o
ad_i486.o ad_i486_clone.o

... snip...

vtune_bsd.o workgroup.o functionAtEnd.o   -lm -lc_r

Linking vm...
trainGeneration.o: could not read symbols: Input/output error
gmake[3]: *** [] Error 1
gmake[3]: Leaving directory
gmake[2]: *** [the_vm] Error 2
gmake[2]: Leaving directory
gmake[1]: *** [jvmg] Error 2
gmake[1]: Leaving directory
gmake: *** [jvmg] Error 2
*** Error code 2

Stop in /usr/ports/java/jdk14.

I've run make clean and tried to build twice with the same result.  CVSup'd a day or two
ago.  Any clues?


More information about the freebsd-java mailing list