jdk1.4.2: plugin & javaws users feedback request

Evan Easton evan at eeaston.com
Sat Dec 20 11:31:11 PST 2003

On Monday 08 December 2003 14:32, Alexey Zelkin wrote:
 > Gentelmen,
 > If you are using jdk1.4.2p5 and also use plugin and/or javaws, then
 > I would ask you send me your feedbacks (positive and/or negative) about
 > their correctnes and functionality.  I am not using them heavily, so
 > not able to test them a lot.
 > Thank you in advance!
I just installed jdk 1.4.2p5 and tried to use javaws on 5.1-CURRENT.  I 
ran into two issues with javaws.

(1) when I run javaws nothing appears to happen.  Top shows javawsbin 
spinning it's wheels using ~40% CPU, but other than that there's no 
outward symptoms it's doing anything useful.  I tried setting env var 
JAVAWS_TRACE_NATIVE=1 , but this did not cause javawsbin to show any 
more info.  I was able to get it to run with the following script:

   java -cp $JAVAWS_HOME/javaws.jar:$JAVAWS_HOME/javaws-l10n.jar \
      -Djnlpx.jvm=$JAVA_HOME/jre/bin/java -Djnlpx.home=$JAVAWS_HOME \
      -Djnlpx.deployment.system.home=$JAVAWS_HOME \
      -Djnlpx.deployment.user.home=/home/evan/.javaws \
      -Djnlpx.home=$JAVAWS_HOME \
      -Djava.security.policy=$JAVAWS_HOME/javaws.policy \
      com.sun.javaws.Main "$@"

So it seems something's  wrong in javawsbin.  I don't know how to 
provide more useful info to you on this.  Give me a hint and I'll try.

(2) Using the above script, I'm able to run some java webstart apps.  
However,  because java -version reports '1.4.2-p5', Java Web Start 
doesn't consider the JRE to be a 1.4.2 **FCS** version and will not 
treat the current VM as valid if a java webstart app wants to run with 
Java 1.4.  Take a look at the jnlp spec. 
.  Look for the text following the syntax for the j2se version command 

    If a platform version is specified (i.e., no |href| attribute is
    provided), Java Web Start will not consider an installed
    non-FCS (i.e., milestone) JRE as a match. E.g., a request of
    the form

         <j2se version="1.4+">

     would not consider an installed 1.4.1-ea or 1.4.2-beta
     JRE as a match for the request. Starting with 1.3.0, a JRE
     from Sun Microsystems, Inc., is by convention a
     non-FCS (milestone) JRE if there is a dash (|-|) in the version 

So this version of the JDK is unusable for apps that  require 1.4 or 
higher (and possibly ones that require older versions of java too).  I 
tried overriding the version from my script above by adding the 
following system property overrides, but no luck:

|  -Djava.version=1.4.2
||  -Djava.vm.specification.version=1.4.2|
|  -Djava.vm.version=1.4.2|
|  -Djava.specification.version=1.4.2|

I haven't tried to rebuild the jdk to report a version of '1.4.2' 
instead of '1.4.2-p5'  but it seems that this needs to be done to make 
javaws usable.  Note that Sun uses a _XX suffix on their patch 
releases.  Perhaps the version reported should be changes to '1.4.2_p5' 
or to be a little more consisted with Sun, '1.4.2_05'.

More information about the freebsd-java mailing list